How to build latest version

This is the forum for JIDE Common Layer which is open sourced at https://github.com/jidesoft/jide-oss. Please note, JIDE technical support doesn't monitor this forum as often as other forums. Please consider subscribe for technical support for JIDE Common Layer so that you can use customer only forum to get a timely response.

Moderator: JIDE Support

Forum rules
Community driven forum for open source JIDE Common Layer. JIDE technical support doesn't monitor this forum as often as other forums. If you only use JIDE Common Layer, please consider subscribing for technical support for JIDE Common Layer so that you can use customer only forum to get a timely response.

How to build latest version

Postby Janne » Tue Feb 27, 2018 12:05 pm

I downloaded version 3.7.2 from GitHub, but it doesn't compile.
Trying to build using ant gives:

Code: Select all
[...]
 [javac] /Users/janne/Downloads/jide-oss-3.7.2/src/com/jidesoft/plaf/basic/BasicPainter.java:3: error: package com.jidesoft.jdk does not exist
 [javac] import com.jidesoft.jdk.JdkSpecificClass;
 [...]
 [javac] /Users/janne/Downloads/jide-oss-3.7.2/src/com/jidesoft/swing/TristateCheckBoxIcon.java:9: error: package com.jidesoft.jdk does not exist
 [javac] import com.jidesoft.jdk.JdkSpecificClass;
 [javac]                        ^
 [javac] /Users/janne/Downloads/jide-oss-3.7.2/src/com/jidesoft/utils/SystemInfo.java:8: error: package com.jidesoft.jdk does not exist
 [javac] import com.jidesoft.jdk.JdkSpecificClass;
 [etc...]

I guess this is because src-jdk8 or src-jdk9 not being built?
Do you have an updated build.xml that works?
Janne
 
Posts: 1
Joined: Tue Feb 27, 2018 3:42 am

Return to JIDE Common Layer Open Source Project Discussion (Community Driven)

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 1 guest

cron