CheckBoxTree single selection is not working

This is the forum for JIDE Common Layer which is open sourced at https://github.com/jidesoft/jide-oss. Please note, JIDE technical support doesn't monitor this forum as often as other forums. Please consider subscribe for technical support for JIDE Common Layer so that you can use customer only forum to get a timely response.

Moderator: JIDE Support

Forum rules
Community driven forum for open source JIDE Common Layer. JIDE technical support doesn't monitor this forum as often as other forums. If you only use JIDE Common Layer, please consider subscribing for technical support for JIDE Common Layer so that you can use customer only forum to get a timely response.

CheckBoxTree single selection is not working

Postby karolinas » Wed Oct 05, 2016 8:03 am

I have an issue with the tree not listening to the specification of its selection mode. I have three trees, and all of them should allow only single selection, that works for one tree, that has only root node and children, but it doesn't work for the ones that have children and grandchildren. Even though I specify the selection node to be SINGLE_SELECTION, and it seems to be the case when I debug it to check whether that's the mode it uses. However, a user is still able to select multiple nodes in the tree. :?: :?:
karolinas
 
Posts: 1
Joined: Wed Jun 22, 2016 3:52 am

Re: CheckBoxTree single selection is not working

Postby JIDE Support » Wed Oct 05, 2016 8:57 am

For this kind of bug report, please provide a test case so that I can compile and run to reproduce the issue.
JIDE Software Technical Support Team
JIDE Support
Site Admin
 
Posts: 36107
Joined: Sun Sep 14, 2003 10:49 am


Return to JIDE Common Layer Open Source Project Discussion (Community Driven)

Who is online

Users browsing this forum: No registered users and 1 guest