Missing com.jidesoft.swing.JideSwingUtilities on OSX

This is the forum for JIDE Common Layer which is open sourced at https://github.com/jidesoft/jide-oss. Please note, JIDE technical support doesn't monitor this forum as often as other forums. Please consider subscribe for technical support for JIDE Common Layer so that you can use customer only forum to get a timely response.

Moderator: JIDE Support

Forum rules
Community driven forum for open source JIDE Common Layer. JIDE technical support doesn't monitor this forum as often as other forums. If you only use JIDE Common Layer, please consider subscribing for technical support for JIDE Common Layer so that you can use customer only forum to get a timely response.

Missing com.jidesoft.swing.JideSwingUtilities on OSX

Postby Homebrewsky » Tue Sep 17, 2013 10:50 am

I have a web app we purchased a few years ago that is now giving me this error from safari/OSX:

An error occurred while trying to initialize SiteScope (Could not initialize class com.jidesoft.swing.JideSwingUtilities), check out your System.error (Java Console by default) for details.

Anyone know why this class didn't make it into the java 1.7.0_40? Or how I can add it back in?

Any help would be appreciated.

Ryan
Homebrewsky
 
Posts: 1
Joined: Tue Sep 17, 2013 10:47 am

Re: Missing com.jidesoft.swing.JideSwingUtilities on OSX

Postby JIDE Support » Tue Sep 17, 2013 10:55 am

It sounds like you may need to upgrade to the latest JIDE release. The class JideSwingUtilities is there. It is probably because of some other changes in the JDK itself which breaks the older JIDE release. You should be able to be find more details in the stacktrace. Anyway, the latest release should have fixed the issue.
JIDE Software Technical Support Team
JIDE Support
Site Admin
 
Posts: 36207
Joined: Sun Sep 14, 2003 10:49 am

Re: Missing com.jidesoft.swing.JideSwingUtilities on OSX

Postby gdanko » Fri Jul 18, 2014 12:24 pm

I am having the same problem with SiteScope and Mavericks.
I have downloaded jide-oss-2.4.8.jar but I do not know what to do with it.
Could you please explain the process required to make this work? I do not want to have to use a Windows VM to access SiteScope.
Thanks
gdanko
 
Posts: 1
Joined: Fri Jul 18, 2014 8:11 am

Re: Missing com.jidesoft.swing.JideSwingUtilities on OSX

Postby JIDE Support » Fri Jul 18, 2014 12:47 pm

Unfortunately I don't know enough about SiteScope to provide any technical support on it. This forum is for developers who write code using JIDE. You probably should contact SiteScope for technical support if they are using JIDE.
JIDE Software Technical Support Team
JIDE Support
Site Admin
 
Posts: 36207
Joined: Sun Sep 14, 2003 10:49 am


Return to JIDE Common Layer Open Source Project Discussion (Community Driven)

Who is online

Users browsing this forum: No registered users and 1 guest

cron